Page 1 of 1

Upgrade LMNucleus 3.66 to Nucleus 3.70?

Posted: Mon Nov 20, 2017 2:53 am
by jacy
Can I follow the upgrade procedure to take a LMNucleus site back to Nucleus?

Also, which version of PHP is LMNucleus 3.66 and Nucleus 3.7 compatible with? My server is running a version of PHP that's going out of support and I need to update but I'm hesitant to break Nucleus. I've been running the same original installation and database since 2004, just applying upgrades along the way.


Upgrade LMNucleus 3.66 to Nucleus 3.70?

Posted: Wed Feb 28, 2018 12:58 am
by dis
Sorry, this is late, but I'll post a reply anyway in case anyone else has a similar question in future :)

It should be fine, I have been mixing and matching LMNucleus bits and Japanese Team Github bits for the last few years and things seem to mostly be working ok :) Though sometimes the plugins may give a little trouble, but most things seem to be fixable so far.

Just make sure you back everything up - files as well as database - before you start your update!

I think I was having a PHP incompatibility problem a while ago too, but right now v3.71 from Github seems to be working quite well.

Note: to go from 3.70 to 3.71, I had to run a database upgrade. It went smoothly though, and I haven't noticed any problems yet! :D