NP_FriendlyComment problem - php5 update needed? - fixed

If you're having questions about some aspect of Nucleus, use this forum.
User avatar
dis
Posts: 209
Joined: Mon Aug 19, 2002 3:56 am

NP_FriendlyComment problem - php5 update needed? - fixed

Postby dis » Tue Aug 09, 2016 12:55 am

Hi all,

My item page comments will not load if I have NP_FriendlyComment enabled. The error message is:

PHP Fatal error: Cannot pass parameter 2 by reference in /var/www/public_html/nucleus/plugins/NP_FriendlyComment.php on line 47.

I'm guessing it is the usual php5 update issue?

If anyone would be kind enough to update this plugin, I would be most grateful.

(NP_FriendlyComment is quite a short plugin so hopefully it should not take too long to fix :))

The plugin code is here: http://nucleuscms.org/wiki/doku.php/friendlycomment
I am using version 1.0, the same as on the plugin wiki. I don't have any newer version to upload.

Thanks very much in advance for any help anyone can give!
Last edited by dis on Thu Aug 11, 2016 9:38 pm, edited 1 time in total.
User avatar
dis
Posts: 209
Joined: Mon Aug 19, 2002 3:56 am

NP_FriendlyComment problem - php5 update needed?

Postby dis » Thu Aug 11, 2016 9:37 pm

i have installed your updated version and comments are loading properly. everything seems to be working correctly now, yay! :lol:
thank you very much for your help, yama! :mrgreen: :D

Return to “General Questions”